Undefined Symbol: __stack_chk_fail_local in Debian

I am compiling panda 1.5.4 in Debian etch. And getting and undefined symbol “__stack_chk_fail_local”.

I’ve diagnosed the problem: the ode and ffmpeg static libraries which are included with the source code under the thirdparty directory have been compiled with option ‘-fstack-protector’ which is not supported by etch and other kernels. I guess that, probably, they have been compiled in Ubuntu, which has this option enabled by default.

Would it be possible to recompile these static libraries using option “-fno-stack-protector”? that would make it possible to compile the panda in all those distribution that do not have that option activated by default in the kernel.



p.s. I also tried to replace the libraries with debian compiled ones, but the version do not seem to match.

Thanks. I’ll put it on my list for 1.6.0.

Hello. I’m also trying to compile Panda3D under Debian/Etch. And I’m getting the exact same error which dix_ans was getting. I have to assume that it’s for the same reason. I also have to admit, that the fact that this bug is over a year old, and was flagged three versions ago, yet that nothing was done about it, has disappointed me.

dix_ans may be the sort of user who simply buys another computer if the one he was using ‘doesn’t work’, l but I take computing seriously. And I also don’t like the fact that all Linux 3D software I’ve run in to so far, discriminates against Debian/Etch.


We’re not discriminating at all against debian. In fact, I do most of the Panda3D packaging on a debian-based system, and I love it.

It’s not true that I haven’t done anything about it. In fact, I’ve phased out the whole concept of the “thirdparty” tree on Linux now, because of these reasons. I didn’t manage to get those changes in the 1.6 series, though, sorry about that.

I advise getting the latest CVS version of Panda3D. In the latest CVS, the build script makepanda will automatically fallback to finding the libraries on the system if the thirdparty library is missing.

In that case I must apologize, for taking a negative attitude this morning. I look forward to working with the CVS version soon then.

I sometimes get up on the wrong side of bed. :blush:


P.S. Just to be a bit more correct, I should volunteer the information, that there exists a lot of 3D software for certain Debian versions. But I happen to be stuck with Debian Etch, which is often considered to be an underpowered version of Debian. This is also why I can’t just install your binaries, either. I have to do a lot of custom compiling.

And I often just wish that actual programmers would not use very high Debian versions all the time. It locks me out. For sure, my next computer will be a Debian Lenny as well. But then this will just lock me out of the next developments. Which all sounds like way too much of a Windows syndrome.