Ubuntu 12.10 - compiled, but pview doesn't run

:display: loading display module: libp3tinydisplay.so
Known pipe types:
  TinyOffscreenGraphicsPipe
(all display modules loaded.)
:framework(error): Unable to create window.

This is what terminal reads when i try to test vanilla pview

i compiled with ppremake, and only got afew errors (unknown args for g++, which were removed in the relevant makefile, and a few lines of code got “this->” added)

I feel like im missing some Graphics pipes…

Best regards

You must have compiled without support for OpenGL and/or X11 which are necessary to open a window. When you run makepanda, it will first output which packages it finds missing, you should look for it and install the development version of the packages you want to build for.

I’m missing alot of packages,

WARNING: Could not locate thirdparty package eigen, excluding from build
Generating library cache...
WARNING: Could not locate thirdparty package artoolkit, excluding from build
WARNING: Could not locate thirdparty package fcollada, excluding from build
WARNING: Could not locate thirdparty package ffmpeg, excluding from build
WARNING: Could not locate thirdparty package swscale, excluding from build
WARNING: Could not locate thirdparty package fftw, excluding from build
WARNING: Could not locate thirdparty package fmodex, excluding from build
WARNING: Could not locate thirdparty package freetype, excluding from build
WARNING: Could not locate thirdparty package gl, excluding from build
WARNING: Could not locate thirdparty package gles, excluding from build
WARNING: Could not locate thirdparty package gles2, excluding from build
WARNING: Could not locate thirdparty package egl, excluding from build
WARNING: Could not locate thirdparty package osmesa, excluding from build
WARNING: Could not locate thirdparty package nvidiacg, excluding from build
WARNING: Could not locate thirdparty package ode, excluding from build
WARNING: Could not locate thirdparty package openal, excluding from build
WARNING: Could not locate thirdparty package opencv, excluding from build
WARNING: Could not locate thirdparty package squish, excluding from build
WARNING: Could not locate thirdparty package tiff, excluding from build
WARNING: Could not locate thirdparty package vrpn, excluding from build
WARNING: Could not locate thirdparty package bullet, excluding from build
WARNING: Could not locate thirdparty package rocket, excluding from build
WARNING: Could not locate pkg-config package gtk+-2.0, excluding from build
WARNING: Could not locate thirdparty package jpeg, excluding from build
WARNING: Could not locate thirdparty package png, excluding from build
WARNING: Could not locate thirdparty package x11, excluding from build
WARNING: Could not locate thirdparty package xrandr, excluding from build
WARNING: Could not locate thirdparty package xf86dga, excluding from build
WARNING: Could not locate thirdparty package xcursor, excluding from build

x11 is the name of alot of packages (when i do apt-get install x11[TAB]), how do I know which one I need?

Is there other packages i must have ?

If you want rendering support, you’ll need at least the libx11-dev libxrandr-dev libxcursor-dev libxxf86dga-dev libgl1-mesa-dev packages. But you’ll probably want things like audio support (libopenal-dev, I think?) and shader support (nvidia-cg-toolkit), support for common image types (libpng-dev libjpeg-dev libtiff-dev), font support (libfreetype-dev) and ffmpeg support (libavcodec-dev libavutil-dev libswscale-dev libavformat-dev).

Awesome :slight_smile: Will try it later