Tut Glow Shader Problems

I was trying to import a separate model in place of Tron.

I’m working in MilkShape and exported my model as a .x file. I converted to an .egg and then used pzip.exe on it.

Now the model imports into Panda alright, but doesn’t glow.

After some fiddling around, I did an experiment. I used punzip.exe on tron.egg.pz and then converted tron.egg in tron.x. After this I examined the file in notepad and noticed something weird. Neither my model nor the tron.x references the alpha textures. So I took the tron.x and put it back through the process and made it tron.egg.pz again. I put this back into the Glow Shader tutorial and he didn’t glow (Note: Other than putting Tron through the conversion process backwards and forwards again, I didn’t change anything).

My best guess is that the .x file type simply doesn’t store the alpha layer needed to make this work.

Is there any other file type I can use to get from MilkShape to .egg or something through 3D Studio Max that will allow my model to glow?

The key line, which you will see in the original tron.egg file, is:

  <Scalar> envtype { modulate_glow }

This tells Panda to use the alpha channel on the associated texture image (tron-glow.png, in this case) as a glow channel. You’re right, this particular flag is not supported by the .x format. However, you can add it by hand after you have generated your .egg file.

On the other hand, if you’re fine with using 3D Studio Max, I believe that the Max egg exporter now properly supports glow shaders and the like.


Oh cool! I’ll give this a try tomorrow. Thank you!