Trying to use packp3d running

I must be missing something obvious, but biting the bullet and asking for help :slight_smile:!

I’ve used packpanda in the past , but now wanted to try to use packp3d and pdeploy

I have a simple test app (“colors”) in a folder on my desktop.
(Created an installer with packpanda first just to verify the app works fine. it does.)

I have Panda 1.9 x64 SDK installed, I installed Panda Run-Time also because I heard that’s needed for packp3d ? (which is odd, but OK)

I tried this from the command line:

packp3d.p3d -o colors.p3d -d c:/users/alex/desktops/colors

presumably I should get a colors.p3d file created?
It runs for about a couple of seconds and I get … nothing
no error , just the prompt back and no file.

I tried explicitly adding the run time’s folder to my PATH and that made no difference.
What am I doing wrong?

btw - I downloaded pdeploy.p3d and packp3d.p3d from

is that the right thing to do also? (doesn’t mention that in the manual, but I read it in some threads as I tried to figure out what was wrong)

I’ve heard that packp3d is not updated for 1.9 yet.

ah, that might be it! :slight_smile:

OK, other than that, have I done what I need to do?
(install Panda runtime, download the 2 .p3d files file )