Trying to run an outdated .bam file (4.3)

I’m trying to load up some old .bam files that I recovered from online, but I am unable to do so.

:util:bam(error): Bam file is version 4.3.
:util:bam(error): This program can only load version 6.0 through 6.30 bams.

How can I view this file? What version of Panda3D do I need?

I am not sure what version of panda you would need in order to view those files, but *.bam files are created for a specific version of panda3d. So you would need the version of panda that created those files.

4.3 is a very old .bam version. The trunk switched to bam 5.0 over 8 years ago. The last Panda version that supported it was probably Panda3D 1.0.5.

Thank you, but i’m having trouble finding this version. The downloads page is missing the installer, Panda3D-1.0.5.exe
(panda3d.org/download/panda3d … -1.0.5.exe)
Any idea where I could find this?

Sorry, we don’t host downloads for Panda3D 1.0.5 any more for the sake of disk space conservation. You may be able to find it on a thirdparty website (I wouldn’t know where), but otherwise, you’ll have to build from source (probably using Visual Studio 2005). Good luck. :confused: