trouble making win32 installer form linux

what I did:
I downloaded makensis sources and binaries zip, compiled and installed in /usr/local/nsis/, made symlink in usr/bin/
makensis run fine from console with test files


pdeply return an error while generating Windows installer, here below last lines of console messages:

:Standalone: Creating /tmp/mysticenglish.exe…
“/usr/local/bin/makensis” -V2 “/tmp/mysticenglish.nsi”
:Installer(warning): Unable to invoke NSIS command.

I noticed that mysticenglish.nsi doesn’t exists in /tmp directory and this is probably why the process halts.
It seems to me pdeploy forgets the creation of nsi file for makensis.

Any thought?

Thank you very much

That’s not the problem. pdeploy simply removes the file after trying to invoke makensis.

The problem is that makensis exits with an error status other than 0, which means something went wrong with nsis. Can you run it directly and see if there are any obvious errors?

makensis runs fine with it’s demo files, so, I should try with the .nsi file generated by pdeploy to see what happen.
Is there a way to avoid pdeploy deletes it?

All other files made by pdeploy are left in tmp/ directory on the contrary of .nsi file , is this correct?

Thank you very much

Hi, I too had problems with this.
I created a python program (although probably a much MUCH better way to do this) that continuesly tried to copy the nsi file into my home directory… I eventually got in and was able to run the makensis command directly…

It appears when the pdeploy program generates the nsi file it forgets to make the license file relative to the directory the pdeploy program was run from!
I can verify this, after I changed the NSI file to have an non-relative path, it worked without the above error. so for instance:

pdeploy -L /home/user/Desktop/game/License.txt" ...

works for me…

Dunno how relevant this is to your problem? I thought I should at least mention it.


Bug report has been filed:

Also thanks for reporting the license file issue, I’ll check in a fix for that.

thank you powerpup118, good idea, I did this way to retrieve nsi file, so, I managed to generate the installer invoking makensis from console, anyway, in my case, pdeploy fails generation even passing the full path to license file.

Thank you rdb for the bug report, I hope someone can get rid of this bug.

Best regards