Trouble getting 3ds max model into panda3d

I have an animated and textured character model in 3ds Max 2011. I have tried two methods, both of which have their problems.

First method: 3ds Max -> export as OpenCollada -> Import to Blender 2.63a -> export to egg using YABEE r12.

For some reason, when I try to view this in the panda3d model viewer, I get a bunch of errors like this:

 column 26:
      <TRef> { arms_normal }
Unknown texture arms_normal

Second method: 3ds Max -> export as OpenCollada -> dae2egg

When I open this egg file using panda3d model viewer, I don’t see my animation or my textures. I just see an outstretched model that is completely white.

I am new to blender and panda3d as well, so please explain to me like I am 5 years old.

You can try the model here:

Unless you use version 2013 then there are exporters for 3dsmax in the Panda3D\plugins dir.
The exporter can do a good job writing animated egg files as long as you use bones or the biped system. Helpers, dummies, geometry is a no-go.

Where is the maxegg exporter? I’m looking in /usr/share/panda3d/plugins, but all I see there are:


There should be maxegg*.dlo and some .dle ( maximport*.dle? can’t remember -but for exporting only the .dlo is needed). If the files are not there then maybe you are using some buildbot version?
But what I think you’re trying to do is run the plugin as a max-script and that’s not how they work. Take a look here: … Studio_Max

I see now. I have to install the Windows version of panda3d to get the maxegg plugins.

I’ve put the maxegg2011.dlo into the plugins folder. But when I run 3ds Max, I get an Error Loading DLLs:

DLL <C:…\PlugIns\maxegg2011.dlo> failed to initialize. Error code 193 - %1 is not a valid Win32 application.

Is it possible that this plugin is incompatible with the 64-bit version of 3ds Max (that’s what I’m running)?

I just tested it with a 32 bit version of 3ds max. The error line is different:

Error code 126 - The specified module could not be found.

I have Microsoft Visual C++ 2012 installed, as well as the 2010 and 2008 versions.

Do I actually need to install Panda3d on the same machine I have 3ds Max running? I thought it was as simple as copying the one maxegg2011.dlo into the plugins folder and that’s it.

At the moment panda3d is not installed on the same machine as 3ds max.

Okay, installing Panda3d fixed the error.

The animation and model exported fine. The textures, however, are completely screwed up. For example, the face texture is missing. Instead, the torso texture is applied to the face along with the actual torso.

Sounds like a multi/sub-object material problem.
The best way is to have one texture per object, not only it gets exported ok, but it can also improve performance -you get one object, send in one batch to the gpu.
The other way would be detaching the faces with other material ID into a new mesh…but that will destroy animations.

It could also be a problem with multiple uvw sets -that’s not supported by the exporter and there are slim chances it ever will be (max not popular with the devs and max users lack c++ skills, finaly max-script is what it is…).

Ah, okay. I will look into texture baking then.

In case something in this thread is left unclear to someone reading it, here are the general limitations of 3dsmax exporting:
You must use a COLLADA exporter, a .x exporter, an .obj exporter or an .egg exporter. Only .x and .egg animations are supported at this time. Panda natively uses .egg so all other formats are converted to .egg either runtime or manually with the commandline tools or other applications like Blender.

If you want to use .egg exporting, you must have Panda3D installed along with max and use the relevant exporter plugin that comes with Panda3D.

At the time of this post, there are no 64bit versions of the .egg plugins. You must use 32bit 3dsmax for exporting .eggs.

At the time of this post, COLLADA support in Panda3D does not support animations so exporting animations with any COLLADA plugin from 3dsmax is useless.

There may also be issues with texture map type names and paths and exporting smoothing group information or vertex/polygon normals with any of the available solutions. This translates into normal maps not working etc. unless the model is processed via the command line egg tools, manually edited to have the correct paths and so forth.