Trouble compiling the panda (CVS) particleSystem


Just a note that when using makepython in windows with:

–nothing --use-pandatools --use-pview

I get errors for each include of any ‘physics’ header from particlesystem. I needed to prefix the includes with ‘…/physics/’ to get panda to compile.

The Sources.pp file does have p3physics in OTHER_LIBS. Not sure what is going on here.

I think --nothing also implies --no-pandaphysics, which is why the particle code doesn’t build. I think the mistake is that makepanda should also not try to compile the particle code when you disable pandaphysics. I’ll check in a fix.

Note that Sources.pp is part of the ppremake build system, which isn’t related to makepanda at all.



Is makepanda preferred over the ppremake system?

Makepanda is simpler, and is recommended unless there’s some reason you need the full control that ppremake gives you. Very few developers need ppremake.