-

Do you have lighting enabled? Since the lines have no normals by default, they won’t respond to lighting properly. You should disable lighting on the lines geometry:

laserNP = render.attachNewNode( laser )
laserNP.setLightOff()

David