threading-model hangs my app

i have a single core Atom N270 PC and a quad core Atom Z3740 PC. if i use thread-model setting , my app doesn’t run at all, on either PC, even if my app has no scene, just a grey window with fps meter, no external library/dll. i tried Cull/Draw, Cull/Cull, and /Draw settings, none works.
what do i need to do with the threading-model setting?
my app runs nearly equally fast on the single core Atom and quad core Atom, so i may need to do something with multi thread stuff.

Do simple apps like pview still work with the threading model?

Are you using code that generates geometry?

  1. pview works with threadingmodel.

  2. my app doesn’t generate geometries, my new test app has nothing in the scenegraph, my older app has geomipterrain which has bruteforce on.

  3. i tested some samples from Panda3D 1.81, i found that “shadow map basic” sample doesn’t run with threading model, the others that i tested still run without problem. on both Atom PCs.

  4. i found one thing strange:
    i use a to launch my, is like this:

import main

with threading model, if i delete the line run() in, then type run() in the python console, my app runs.
even if i add a line: time.sleep(10.0) or Thread.sleep(10.0) before the line run(), the app still doesn’t run.
i don’t know the difference between having run() in and typing run() in the python console, that’s really strange.

  1. on either of my PCs (Atom N270 has single core, 2 threads, Atom Z3740 has 4 cores, 8 threads), threading-model doesn’t improve the framerate of my older app with a geomipterrain and some onscreentext. both PCs still run nearly equally fast (normally above 50fps). that’s with unlimited clock mode.
    but my app has a function which limits framerate to 30fps, using Thread.sleep (Thread imported from Panda3D). if i turn on the function, my app has much longer sleep time, app process time is cut by more than half.

  2. with threading model on, and unlimited clock mode, my onscreentext flashes.

  3. only Cull/Draw setting works, the other settings hang my app no matter what.

8) my Atom N270 PC has WinXP SP3, Atom Z3740 PC has Win8.1 32bit.