texCUBEbias vs texCUBE

From demomaster version 0.1:

In this ocean shader (share/shaders/ocean2.sha) :

	    float4 R;
	    R.xyz = reflect(E, N);
	    R.w = reflectionBlur;

	    reflection = texCUBEbias(tex_3, R);
		//reflection = texCUBE(tex_3, R);

I find that texCUBEbias seems not work as expected, it functions like texCUBE instead. I am on Windows XP, it is a bug or it is my program bug?

Hmm, I don’t know. Can you try choosing a different shader profile, such as vp30 fp30? (this also requires setting basic-shaders-only to #f)

The result is the same for the profile you suggest.
I think this is pretty basic function ?

Well, I don’t see how it could be a bug in Panda. Panda just passes the shader to the Cg compiler, (which is part of the NVIDIA Cg Toolkit).
The only thing I can think of is a bug in cgc, or the profile you’ve chosen doesn’t support it. If you’re on linux, typing “man cgc” at the console will list available profiles. This page lists all the profiles (but you probably have an older version of the Cg Toolkit).
If you’re on windows, try switching to the DirectX 9 driver.
You can also try googling to see if there are any other users with the same problem.
Or, it’s a bug in your code.

The toolkit should be come with Panda, is that right ?

I am on Windows, but I have problems in using DirectX driver with Panda. I have a 9500 GT, which is quite new.

Would you mind testing it on your machine for this case, if you have time ?

In demomaster, select Ocean 2, then on the attribute panel, select the attribute “Relection Blur”, change this parameter will see a change on the screen, if it works.

Hmm, I don’t see a noticable difference.

Ok, it is strange…likely it is my shader problem? May be I find other shaders to test it again later. Thank you.

Ok. It is my problem. The texCUBEbias actually bias the mipmap level, so I need the enable mipmap on the cubemap in order to make it work.