TaskMgr problem in Karmic.

Following a suggestion here I went ahead and updated to Ubuntu Karmic Koala today(it officially comes out tomorrow). I searched the threads for the problem I am having and could not find it described elsewhere(doesn’t mean it does not exist, mind).

Basically the problem I have is in running through the third part of the hello world example from the manuals-Controlling the Camera. The scene itself loads fine, except the screen does not update to show the revolution of the camera. It is just a plain static image. I added a print command to the SpinCameraTask function to print angleradians and can verify that the variable is being updated every iteration. So, being a noob to Panda my assumption is that the problem is in the taskMgr.add or the return Task.cont.
Any help would be greatly appreciated.

Here’s the code to verify I did not manage to screw it up. I just added the shebang and the print command I mentioned above.

#!/usr/bin/env python

import direct.directbase.DirectStart
from direct.task import Task
from direct.actor import Actor
import math
#Load the first environment model
environ = loader.loadModel("models/environment")
#Task to move the camera
def SpinCameraTask(task):
	angledegrees = task.time * 6.0
	angleradians = angledegrees * (math.pi / 180.0)
	base.camera.setHpr(angledegrees, 0, 0)
	print angleradians
	return Task.cont
taskMgr.add(SpinCameraTask, "SpinCameraTask")


Try calling base.disableMouse(). Without this call the camera will be reset every frame to your trackball position.


Thanks for the advice(starred it in my notepad) but it didn’t work. The screen is not moving at all. Mouse input or no mouse input. I let it sit for a while for good measure and no dice. But I will keep tinkering and if anyone is willing to keep helping me, I’d like to get it sorted out. Thanks all :slight_smile:

For the record, I’m running Ubuntu Karmic Koala myself and that exact code you’ve posted works fine for me - the camera rotates nicely, and the time is printed out every frame.

Could it be a driver issue? Do any of the Panda samples show movement for you?


No dice. I run the tutorials and get the light deprecation error on some(which a search of the forums say is known) and the others do not update at all once the initial screen loads. I am going to attempt an install through the cvs source and see whether or not that fixes the issues for me. Will keep everyone posted and thanks for the input thus far. :slight_smile:

Well, it sounds more like an issue with your drivers, than with Panda itself. You should try updating your graphics drivers first.


(in Ubuntu, you can do that by clicking System > Administration > Hardware Drivers.)

Thought I would let everyone know that I uninstalled and reinstalled panda and it worked. I went ahead and updated the drivers just to be double safe. Thanks everyone for the advice.