Struggling with x2egg


I’ve got some models in .x format that I can open perfectly well within a .x viewer but x2egg refuses to convert them.

It gives this message:

Error in Ball.x at line 7857, column 12:
DeclData {          ^
Unknown template: DeclData
Warning in Ball.x at line 17222, column 3:
Too many data elements in structure.
Warning in Ball.x at line 17223, column 2:
Too many data elements in structure.
Unable to open X file: Ball.x
Unable to read Ball.x

The file is just a very simple, untextured sphere so I wasn’t expecting any problems. If I remove the ‘DeclData’ entry in the .x file then the converter works fine but I can’t load the model within my Panda code.

I’m really beginning to struggle with this now so I’d be very grateful for any pointers.


It means the .x file is invalid, I think. Some .x writers are known to generate invalid .x files. Some .x readers can read them even though they are invalid.


Thanks for the info. The original images were created in Maya so I solved the problem by exporting as Maya and then using maya2egg which worked perfectly.