Strange problem playing ogg files

Playing ogg files i found something strange.I load an ogg file (i tried with different ones) and play it.

mySound = base.loader.loadMusic('mymusic.ogg')

Then i stop it


And then when i tried to reproduce it again from the begining calling play() again, before the music start over i can heard a small part of the previous one (like an old buffer).

Is this a known ploblem? or Do i missing something?


First I’ve heard of this problem. Does it also happen with .wav files? What operating system are you on, and which version of Panda? Which sound interface are you using–OpenAL or FMod? Have you tried switching to the other sound interface (if you’re on Windows)?


Hi David,
Sorry, I forgot to put my data in the last post:

  • Panda 1.8.1
  • Windows 7
  • OpenAL

I think it didn’t happen with wav files, but let me try again and i’ll tell you.
I didn’t try FMod library because i was looking for a free alternative but i can try it just to see the result in this particular case.


Hi again David,
I did the tests and it seems like the problem is only happening with ogg. I tried with flac and wav and it works fine.
Ogg with fmod works fine too.

Is there some work arround to avoid the problem using openal?


Please file a report on the bug tracker and attach your .ogg file with some simple Python code to reproduce the issue, and someone will take a look at it.

Done. Thanks rdb.