[Sovled] P3D 1.8 and Bullet

I found out P3D 1.8 had Bullet integrated into it, and I switched because I had more knowledge using Bullet than ODE…

However, when I tried to import anything from Bullet into my Python script, Panda3D can’t find the module

from panda3d.bullet import BulletWorld

leaves with the message

ImportError: No module named bullet

Any reason why this could’ve happened? Am I missing something?

hrm i tried

and it worked just fine. Panda 1.8 python 2.7(havent changed pythoin path to 3 yet =/) can i see more of your code?

I agree. A little bit more information is required, like OS or Panda3D buildbot Version you are using.

You can also assert a few things up in front:
1.) Bullet is quite new and not available in very old Panda3D versions already flagged as “1.8”. So make sure to have a brand-new buildbot version installed. Best would be not older than two weeks.
2.) Can you see the libpandabullet.dll in Panda3D’s /bin folder? (assuming your OS is Windows… similar for other OS-es)
3.) Do other Panda3D imports work fine in the very same script, e. g. “from panda3d.core import Point3”?

  1. Using newest one that came out
  2. I see the .dll file in there
  3. Other import like Vec3 work fine…

Could me having 1.72 Installed have something wrong with it?

Yes, could be. Try to uninstall both and then do a fresh install on the buildbot version.

After reinstalling and screwing around with my code, I somehow go it working now…
Yay!

Now I just have to figure out how to use it with Python -_-