Soundsystem Bugs, OGG & FLAC fail.

unfortunately i hit another quite serious issue lately.
when i tried to play a number of audio files i found that some of them reproducably crash panda, play only a short time of their actual duration or already bring down panda when simply loading the file.

code and sample files can be found here:

i’m on ubuntu 10.04_64 , default panda package from the download page. following errors occur:
-fmod lib seems to be missing entirely
-playing an ogg file > 15 seconds with setLoop(True) crashes panda when it finished playing it once.segfault. running traceback points to some ffmpeg stuff.
-playing ogg files <10 seconds often results in audio only playing the first second, then remains silent, but at least loops.
-loading ogg files <5 seconds sometimes works, sometimes produces strangly broken audio for a split of a second, then silence, but loops.
-loading a flac file immediately crashes with

terminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc

when i dont loop the sounds, the ogg >10seconds file plays nice.

situation for now. ogg is semi-broken, flac entirely unusable. no need to explain the seriousness any further.

any ideas how to fix this?

Have you tried a CVS version? We fixed a bug in ffmpeg that caused some sound files to stop after some seconds. You didn’t mention if you are using ffmpeg, though, but it sounds a lot like this bug we fixed.

And that is for OGG, the flac crash seems unrelated.

tried to run the daily builds which fails due to missing opencv library.
i havent tried trie cvs and self-compile yet.

traceback of the opencv crash… just in case someone is interested in it (it’s entirely unrelated to the actual topic,thought)

Traceback (most recent call last):
  File "", line 3, in <module>
    from pandac.PandaModules import loadPrcFileData
  File "/usr/share/panda3d/pandac/", line 32, in <module>
    from libp3visionModules import *
  File "/usr/share/panda3d/pandac/", line 2, in <module>
  File "/usr/share/panda3d/pandac/", line 79, in Dtool_PreloadDLL
    imp.load_dynamic(module, pathname)
ImportError: cannot open shared object file: No such file or directory

On WinXP 64 bit and the latest snapshot built there is also problem with OpenAL and ogg files. The music will play kinda ‘jerky’ when alot of things are happening in the game and sometimes python will just crash. There isn’t an exact moment when it will happen.
Btw, the comment from prc file says

but its set to OpenAL anyway

A quick fix (make the first argument your actual libcv so file):

sudo ln -s /usr/lib/ /usr/lib/

A quick fix (make the first argument your actual libcv so file):

sudo ln -s /usr/lib/ /usr/lib/