Something screwy with the online manual.

I noticed this when I went to the online manual yesterday, and it’s still happening today. I just closed Firefox and updated from the Mozilla Daily PPA to ensure that it wasn’t my browser.

Basically, when I go to any page in the manual and try to switch languages (between Python and C++), I get taken to with either ?python or ?c++, and what shows up on the screen is “Click here to return to the page you were visiting.” That seems about right. However, it goes into hyperactive refresh mode or something after that, almost like changelang.php is redirecting the page to itself. It never reaches the destination; only seems to travel in a loop.

Is anyone else getting this problem or is it just on my end?

No problem here.

(Using Google Chrome on Windows XP SP2)

confirmed. same problem here

(i didn’t notice it earlier because i only code python)

I generally work with only Python as well. Only very recently have I tried to dabble a bit with the C++ side. I know the language switch worked not too long ago, but I don’t know exactly when it started to fail since I wasn’t using it daily.

For the sake of principle, and for a touch of humour, I would have to say that Google Chrome on Windows should never experience fewer problems than Firefox on Linux. The only thing worse would be an Internet Explorer user coming and saying that he, too, is not experiencing the problem.

just noticed that it works if you go back to the manual again. seems like the switch only sets a cookie and doesn’t forward you to the desired pages.

Oh, I coughed up the changelang script in a split second. It worked for me then, and it doesn’t really surprise me that it doesn’t work in some obscure browser+os+settings combination.
It’s supposed to automatically redirect back, but probably your browser does not support/allow that kind of redirect.

I’m out of the country right now, but I’ll take a look at it when I get back. Can you guys tell me if it works for you, and tell me your browser + OS?

[size=75]Uh, it works in IE7, too…
Maybe it’s a Firefox thing.[/size]

works fine for me on firefox 3.5 , ubuntu 9.04_64 ,works fine on google chrome ,too.
it breaks on both browers if i open a new tab, copy the adress, and hit enter.(cause there is no previous page it gets stuck in infinite reloading).

however both work fine when having swithing the language from a manual page (like intended).