[SOLVED]Spotlight Near Far Trouble

If I understand P3D’s light functions correctly… Fov on a spotlight will change its field of view, making the light cover a wider area of effect.

Setting the NearFar controls the distance of the light from start point to end point.

I think I have something wrong in those statements.

I am trying to make my spotlight extend only so far in distance by setting the NearFar, but no value will change the distance.

#No matter what value you have...nothing changes

The near far settings only apply to shadowing. If you want to change how far the light reaches, you need to tweak the attenuation settings.

I knew about the attenuation setting, I just thought it was for point lights only. :slight_smile:

Since light goes through walls in P3D, it’s impossible to contain light in one room manipulating light settings. The best way is to assign lights to each level part (which I was going to do anyway) and make sure those lights do not effect objects or walls from another level part.


I also learned how to Bake Specular Maps with Blender. Most people on the net say it’s impossible with Blender but not so. The thing is, why just bake a spec texture map when you can really bake a fully completed texture (normal, spec, dis, shadow, ambient, etc)?

Here’s an example I made:


Of course, I still have to combine all textures into an Atlas according to how I will flatten them.