[SOLVED] setBin, 'background' and transparency

It seems I’m still a bit confused about setting render order for a model.
I have a skydome and set it’s ‘bin’ to ‘background’. It works as expected, but when I set a transparent cloud quad to background, it doesn’t show up. I’m guessing it has something to do with texture transparency…

EDIT: The problem was setting transparency options in Blender. When not setting anything but having a transparent texture it works as expected. I don’t know why, but it is solved.

Do you want to render the cloud before or after the skydome? I’m guessing after. Since ‘background’ is a fixed-type bin, you can specify the relative ordering of things in the background bin with the second parameter, e.g.:

skydome.setBin('background', 0)
cloud.setBin('background', 10)

David

I guess you could do without reparenting the clouds to the background bin. Look at this one for example: discourse.panda3d.org/viewtopic.php?t=6688