[Solved]Panda3D-1.6.2 - Failed 2 Run

Hi Guys ,

i’m trying to compile panda3d with no success.

i have visual studio 2008 , i downloaded Panda3D-1.6.2
Created a new project and linked all the VC++ Directories
from the Tools -> Options menu , add the Additional Dependencies
in the Linker - > Input Tab.

Then i tried to run the project and it failed to run.
it says from the panda console :

:loader(warning): Unable to load libp3ptloader.dll: Invalid access to memory

What should i do ?

Wait, you’re trying to compile Panda3D, or you’re trying to compile your own application that links with the already-compiled Panda3D?

If you’re trying to compile Panda3D itself, you should use makepanda to do this. It sets up the correct flags for compilation automatically.


Hi david ,
thanks for your quick reply

as for your question , i am trying to compile the quick example
from the panda3d manual …
even the sample pograms that comes with panda3d does not work.

Did you set your project to “Release” mode? Trying to build a “Debug” project is the most common error; that will crash. Only a “Release” project will run successfully.

But when you say “even the sample programs do not work”, I’m concerned. Do you mean the Python sample programs don’t work? In what way do they fail? How about “pview”, can you run that? Obviously, if your installation of Panda is so broken that it can’t run its own programs, then it’s not going to be able to run your programs either.


Yes i forgot to mention that , i set my project to “Release” mode

I’ve tried running “pview” also failed , Output :

Known pipe types:
(all display modules loaded.)
:display:wgldisplay(error): SetPixelFormat(57) failed after window create
:display(error): Window wouldn't open; abandoning window.
:framework(error): Unable to create window.

I do not know if it’s related but when i first run a panda3d sample program there was a missing dll (MSVCR71.DLL) although i had visual C++ 2008 Redistributable package so i downloaded the dll and put it in system32.

OK, that’s an unrelated problem. The SetPixelFormat() error is a known problem with certain graphics drivers. This is discussed, along with a temporary workaround until the next Panda release, on this thread: https://discourse.panda3d.org/viewtopic.php?t=6541

Once you have taken care of this problem and gotten pview to run, and presumably the sample programs as well, we can then take another look at the problem that’s preventing your own application from running.


Thanks a lot david! , i just changed :

load-display pandagl


load-display pandadx9

and it works just fine!
if its such a common problem maybe it worth mention it in the manual ?
thanks agian!