[solved] dxgsg8(error) CopyRects failed in copy_texture


I’m still fighting with my ATI Radeon X1400 graphics card.

I get the follwing error in the “render-to-texture” demo. The teapot is not visible, there is just garbabe showing in the heads.

The ATI card uses HyperMemory (sharing a part of the notebooks memory for the graphic card). Maybe this is the source of trouble…

:display:gsg:dxgsg8(error): CopyRects failed in copy_texture at (panda/src/dxgsg8/dxGraphicsStateGuardian8.cxx:1436

The same happens in the motion trail example.

Any ideas?


It could be, that your video card doesn’t support all these things.

It would be interesting to know if it worked in OpenGL or DirectX9 modes. Each different API uses a different method to achieve render-to-texture.



yes there is a different behaviour if I active pandagl mode:

DirectStart: Starting the game.
Warning: DirectNotify: category 'Interval' already exists
Known pipe types:
(3 aux display modules not yet loaded.)
:display:wgldisplay(error): SetPixelFormat(47) failed after window create
:display(error): Window wouldn't open; abandoning window.
C:\Panda3D-1.3.2\direct\src\showbase\ShowBase.py:410: RuntimeWarning: tp_compare didn't return -1, 0 or 1
  if pipe.getType() == pipeType:
:display:wdxdisplay9(error): adapter #0 CheckDeviceType failed for surface fmt D3DFMT_A8R8G8B8
:display:wdxdisplay9(error): adapter #0 CheckDeviceType failed for surface fmt D3DFMT_A8R8G8B8
:display:wdxdisplay9(fatal): Can't create any screen buffers, bailing out.
:display:wdxdisplay9(error): fatal: must be trying to create two fullscreen windows: not supported
Assertion failed: _d3d_device != NULL, file panda/src/dxgsg9/dxGraphicsStateGuardian9.cxx, line 2382

I set load-display pandagl in the config.prc.

What I’m wondering is that the error line seems to be coming out of the directx-source.



update, and good news: I downgraded the ATI X1400 driver to the previous (“old”) version. Now everything is running well under dx9 and opengl. Even shaders are now working.