[SOLVED] (Blender) camera follow path

That mopathNP doesn’t contain anything - almost certainly because the call model.find("**/curve") couldn’t find a node with the name “curve”. This is the same problem as you had previously with finding ‘playerstart’ basically.

This is pretty basic stuff - if your struggling with this you really need to work on your understanding of what is going on, otherwise your going to constantly hit problems and be unable to solve them.

No, it’s my english:

^ I was asking for this

Tried this again today and no luck. Do I need to add a property to the curve or something? Couldn’t find anything being mentioned about that in the manual.

Yes, but when the node ‘curve’ is a mesh type in Blender, it can find it…

Hmmm, not sure - I need more information really. Any chance you could post or email the .egg file?

Sure, here are an example blend, egg and py files: mediafire.com/download.php?bnmtn0tmyzh

It appears that curves get a number appended to there name - your curve was called ‘a0’ in the file (Just open the egg in a text editor and scroll to the bottom - curves are always last.) - changing your application to search accordingly fixed the problem, though your going to need to work on that curve! I hadn’t realised this strange naming convention exists (Curve code was inherited - never looked too closely.). I might fix this with the next chicken release.


Please do so. I wonder why anyone hasn’t reported this before.

Why? : mediafire.com/?oyjiykjtmz2
Anyway, I should start a new thread, my current task problem is completely unrelated…

I’ve only had curves brought up previously once before - I don’t think this feature gets much use! For future reference though its very easy to print out the node structure or open the egg file in a text editor - if you do that then things like unexpected names jump out at you almost instantly.

When I ran the program with the curve the geometry you had was on screen for less than half a second - hence the suggestion it needs work:-) Just a throw away comment really.

Too bad.


Oh, that? I forgot something, here is how it should have been: