Snow Leopard install issues

I’ve read a bunch of posts and tried getting this to work to no avail.

Running any samples, I get the error message :
StandardError: No graphics pipe is available!
Your Config.prc file must name at least one valid panda display
library via load-display or aux-display.

I checked my paths and I have :

I’ve also loaded python and run ‘getPluginPath’ which returns :

I’ve checked that path and it does contain ‘libpandagl.dylib’

Still doesn’t seem to find it. Am I missing something?

Running on Mac OSX 10.6, panda3d 1.6.2 from the .dmg install, /usr/bin/python is version 2.6.1, but I’ve also tried python2.5


Posted 10 mins too soon…

For anyone else getting this problem, read up at : … c9bcf2ef61

This is the part that solved my issues :
sudo ln -s /usr/X11/lib/libOSMesa.7.dylib /usr/X11/lib/libOSMesa.4.dylib

I am on regular Leopard (10.5.8), on an Intel based mac mini. I get the same error. Just for the heck of it, I tried the fix mentioned in the above post…no joy, still getting the error. I realize that the mini is gonna have limited capability with the graphics chip, but it would be nice to get some minimal functionality.

Further info…in my earlier post, I hadn’t tried the bit about unpacking the Cg.framework thing. However, when I do this, I find that there is already an older file folder with that name in my Library>Frameworks folder.

Is this something i dare overwrite?

Weird. I can run Panda fine on a Mac Mini (in fact, I compile Panda on one).
You could try upgrading the Cg framework, but that doesn’t have anything to do with libOSMesa, so it probably won’t help.

Can you try running a software update, though?

When you say software update…are you talking about the standard Apple software update, or something else?

The standard Apple software update.

well, according to Software Update, I am up to date.

I am wondering what other programs depend on that file folder and if I could perhaps rename it and substitute the one mentioned in the tutorial.

Are source compiles on a mac similar to those on Linux? I.e.

make install?

Does one have to go through dependency hell like on linux, running ./configure recursively until dependencies are satisfied?

Nah. Get the source, and invoke this:

python makepanda/ --everything --installer

If it succeeds, a .dmg should appear in the current directory.

I followed the above instructions, but, while it did create a “built” directory, it did not make a .dmg file. Not sure where to proceed from there. I have an intel based mac mini, if that makes any difference.

That probably indicates that the compilation did not finish. What is the last part of the output?

At risk or stealing this thread (at least partially)…

@rdb - what CPU do you have in your Mac mini, and do you use Snow Leopard ?

$ file /Developer/Panda3D/lib/*.dylib
/Developer/Panda3D/lib/codec_aiff.dylib:                Mach-O universal binary with 2 architectures
/Developer/Panda3D/lib/codec_aiff.dylib (for architecture i386):	Mach-O dynamically linked shared library i386
/Developer/Panda3D/lib/codec_aiff.dylib (for architecture ppc):	Mach-O dynamically linked shared library ppc

Apparently Panda 1.7 is compiled with only i386 and ppc but not x86_64 support (i.e. will work only on core duo and powerpc, but not on core2duo and Xeon unless Python is set to run in 32-bit mode)

as seen by:

In [1]: from direct.fsm.FSM import FSM
Traceback (most recent call last):
  File "<ipython console>", line 1, in <module>
  File "/Developer/Panda3D/lib/direct/fsm/", line 8, in <module>
    from direct.showbase.DirectObject import DirectObject
  File "/Developer/Panda3D/lib/direct/showbase/", line 6, in <module>
    from direct.directnotify.DirectNotifyGlobal import directNotify
  File "/Developer/Panda3D/lib/direct/directnotify/", line 3, in <module>
    import DirectNotify
  File "/Developer/Panda3D/lib/direct/directnotify/", line 5, in <module>
    import Notifier
  File "/Developer/Panda3D/lib/direct/directnotify/", line 6, in <module>
    from direct.showbase import PythonUtil
  File "/Developer/Panda3D/lib/direct/showbase/", line 60, in <module>
    import direct.extensions_native.extension_native_helpers
  File "/Developer/Panda3D/lib/direct/extensions_native/", line 81, in <module>
  File "/Developer/Panda3D/lib/direct/extensions_native/", line 79, in Dtool_PreloadDLL
    imp.load_dynamic(module, pathname)
ImportError: /Developer/Panda3D/lib/libpandaexpress.dylib: no appropriate 64-bit architecture (see "man python" for running in 32-bit mode)

I compiled it on Leopard, that means no 64-bits support. You’ll have to run Python in 32-bits mode.

So what exactly does one need to do, to run panda3d in Snow Leopard?

How do you run python in 32-bits mode? Can you set that as a default? I have seen it mentioned a few times, but I am having trouble actually doing it.


The manual page for Python (type “man python” in the terminal) explains how to run Python in 32-bits mode. That’s the only thing you should do, I think.