Slow startup time on my Vista laptop

I’m wondering if someone here has encountered a really long startup time (like 15-20 secs) when starting Panda?
When I start any of the samples my mouse freezes + the clock on the desktop freezes for about 15-20 secs, then the panda window appears.
When it’s running all is well, no performance problems there.
I’m running with Panda 1.7 on Vista on a HP laptop.

I had some similar issues a couple of years back when running Ogre with OIS, it took quite some time to start up.
But when testing Horde3D last year it started really quick (in a couple of seconds).

So any tips on what might going on on my system would be highly appreciated… it’s a pain when I’m testing out Panda…
(I’m wondering if it’s something with the input system on my PC…)

Btw, when testing the same thing at work on a desktop comp running Win 7 it starts really fast.

Gogg recently put in some changes to improve startup time, but what you’re describing sounds more chronic.

A curiosity: you don’t, by chance, have “want-pstats 1” in your Config.prc file, do you? If you do, it will attempt to contact whatever host you set in “pstats-host” at startup time, and that network communication attempt can sometimes lock up the process until it times out.


No, I have that setting disabled.
I’m running with the 1.7 exe-version gotten from the download page.

does the pc in your office has the same hardware specs as your pc at home? well, except the Win7 and vista mentioned earlier.

Have you tried pview.exe to see if you get the same delay? Because maybe the problem is Python related.

@simonmorrison23: No, the hardware at home is different from that on the work… were you thinking of some special hardware component?

@Gogg: Yes, I get the same delay with pview.exe. Also when testing from C++ the same delay is there.

When starting up and running with notify-level “warning” it freezes after these lines are printed out to the console:
Known pipe types:
(all display modules loaded.)

And when running with notify-level “debug” it freezes after these lines are printed out:
:display:windisplay(debug): WM_SIZE: 000605E6, 0
:display:windisplay(debug): WM_ACTIVATE: 000605E6, 1, 0
:display(debug): system_changed_properties(foreground !minimized )
:event(debug): Throwing event window-event(wglGraphicsWindow)
:display:windisplay(debug): setfocus
:display(debug): system_changed_properties(foreground )
:task(debug): AsyncTaskManager TaskManager task chain loader; 0 tasks: set_num_threads(1)

I tested on another similar laptop at home, and on it the startup time was only a few seconds.
So it seems to be something wrong with the setup on my system (either hwardware or software).

I can’t figure out Windows… :open_mouth:
In my device manager I had a HP remote control and a USB remote control, I uninstalled these and upon reboot the devices had reinstalled themself!
And the result of this: Panda3D starts really fast on my laptop now! :smiley: