Silly newbie question =) In reading the manual, I notice some conflicting conventions when assigning node names. For example, this page about the physics system contains the following snippet:
node = NodePath("PhysicsNode") node.reparentTo(render) an = ActorNode("jetpack-guy-physics") anp = node.attachNewNode(an)
As you can see, the node variable has the generic name “PhysicsNode” which only specifies broadly that it’s physics-related. The an variable is very specifically named to show that it is the physics node for the jetpack guy.
At this point I would still have assumed that more specific names are better, and written off “PhysicsNode” as a small oversight. However, the next page of the manual has this line
This makes it sound like the node name is actually more of a “group” name! I could imagine gravity, drag, wind, and other ForceNodes all being given the name ‘world-forces’, perhaps so it’s easy to search for the lot of them later on.
So now I’m not sure. Is there a “right” way to name nodes? Are they meant to describe exactly the purpose of the individual node, or to put nodes into broad categories? Or, is it just an arbitrary field that I can freely use in whatever way seems best to me? =)