Shadow samples still not working in 1.7.1

Just got Panda 1.7.1 installed! :smiley:
So, I tried out the Shadows samples again, to see if they worked, as they hadn’t with 1.7.0.

They didn’t.

I had the same problems I experienced with 1.7.0 (see this thread for the details).

Anyone know what’s going on?
As always, I’m using Ubuntu 10.04 (Lucid Lynx) with an Intel GM45 GPU.

Yeah, I have the same… The Advanced sample works like a charm, but Basic doesn’t. The light is there, but no shadows of the teapot, panda.

Ubuntu 10.10, GF GTX460.

According to the conversation in the IRC the patch was accidentally not picked up in the 1.7.1 release but in the updated debs it should be fixed.

Ive come to the conclusion that the built in shadow casting will not work with my video card. BUT the shadow mapping advanced tutorial works just fine. Basic does not, but oh well.

whatever the case, i jsut wanna cast some shadows. the problem is, with the shadow.sha included in the tutorial, my textures arent represented…

any help?


Yeah, it works in the updated debs. Checked the samples and own code – everything is fine now.

Okay, I’m checking…

I tried re-downloading 1.7.1, but it still doesn’t work.
Do you mean a buildbot build?

No, the official debs. Hm… maybe Rdb only updated the Maverick builds?

The version number should be 1.7.1-1~lucid1. Note the -1 after 1.7.1.

I’m looking at the deb downloads now, and the Lucid Lynx package is just 1.7.1, not 1.7.1-1.


As far as I can see, the names aren’t updated, either for Maverick or Lucid. But, at least for Maverick, it correctly says “1.7.1-1” when you try to install.