Shadow sample does not work in my laptop

i installed Panda3d 1.7.2 but when i run Shadow sample i cant see any shadow. Just dark seen that panda is running and teapot is rotating.
but when i install Panda3D 1.6.2 everything is Ok and i can see shadows.
and in 1.6.2 version Fireflies sample work better and faster than in 1.7.2.
i want to use 1.7.2 but it seems 1.6.2 is better.
can anyone help me?

We’ll need a bit more information than that. Your system, your drivers, whether they are updated to the latest version, etc.

Thanks you rdb
OS : Vista
CPU : Intel Core 2 Duo P8700 2.53 GHz
Graphics : ATI Mobility Radeon HD 4500 Series
Opengl Version : 3.3.10665
I changed it to directX in configuration file but nothing changed.
My driver is updated.
i said that everything is ok in Panda3d 1.6.2.

Hmm… can you try changing the shadow sample? There should be RTPDepthStencil in there somewhere, try changing it to RTPDepth (or if it is already set to RTPDepth, try changing it the other way around).

Thank you rdb
Problem solved.
i changed fireflies sample too and it works well.
can you tell me what was the problem?

What did you change it to, exactly?

I changed RTPDepthStencil to RTPDepth.
just this.