I’ve asked this in one of the other threads, but noone has answered.
When I export my model from 3ds MAX 9 using the 3ds max9 egg exporter and view it in the Panda viewer I can’t see the shading of my model. What am I doing wrong? Doesn’t the illumination/shading information get exported?

I think the reason nobody answered is that of the two big Panda3D maintainers, Disney and CMU, neither uses Max. We just don’t know. It seems likely that we have a few Max users here on the forums, but they aren’t always as diligent about answering questions as the big two.

To make matters worse, the Max exporter is a known disaster area. We are planning on doing a complete rewrite this summer.

“Great” :frowning:

Can’t wait til after summer. I need this for an exam project :confused:

Well, guess I just need to do some more “fumbling in the dark” and hope to bump into a solution :neutral_face:

How do you export shading informations?

If you mean normals, they should get exported like usual. If you mean lights, those are not exported. But you can render a light texture and apply it to the model.

Also check the pview buttons “l” enables lights…

  • A better route would be to convert Max to Maya, and use the Maya exporter to export it to .egg.
  • pview doesn’t show shading of it’s own, by default. press L to enable lighting (as Hypnos said) and P to enable per-pixel lighting.

BTW. There’s a difference between shading and shaders. Which one do you actually mean? No, the max exporter doesn’t support shaders.

Thank you very much for the answers. I didn’t know that lights weren’t on by default in the previewer (I’m very new in the use of Panda3D). :blush:
So that was the problem, now my character is displayed correctly.