Shader generator silently failing

Hi Panda3d community!

I’m new here. I’ve been working on a small project in my spare time, using Panda3d and Python - love it!

Anyways, I cannot seem to get any of the auto shader text modes to work… :frowning: The code I’ve written is below. I’ve tried rendering with both a directional and point light, neither seem to work. I’ve tried drawing my object without the diffuse texture, but all I see is a solid white cube.

Am I doing something wrong? Or could this be a bug with my machine?

Panda 1.8.0 on Windows 7 x64 Python 2.7
2 nVidia 460s (SLI disabled for now)

        texture = loader.loadTexture(self.texture)
        normal_map = loader.loadTexture(self.normal_map)
        height_map = loader.loadTexture(self.height_map)

        geometry = loader.loadModel("media/models/cube.egg")

        texture_stage = TextureStage('diffuse')
        texture_stage.setMode(TextureStage.MReplace)
        geometry.setTexture(texture_stage, texture)

        normal_stage = TextureStage('normal')
        normal_stage.setMode(TextureStage.MNormal)
        geometry.setTexture(normal_stage, normal_map)

        parallax_stage = TextureStage('parallax')
        parallax_stage.setMode(TextureStage.MHeight)
        geometry.setTexture(parallax_stage, height_map)

        geometry.setScale(self.size, self.size, self.size)
        geometry.setShaderAuto()
        self.geom = geometry
        return geometry

UPDATE: Doesn’t seem to work with DX9 or OpenGL

SOLUTION: The code above works… It turns out my model, exported from Blender using Yabee, was missing binormal and tangent data. Running “egg-trans.exe -tbnall -o ‘path/yourfile’ ‘path/yourfile’” solved the problem.