setColor does not work in v1.9.2?

I got nervous when all my imported models became white after updating my project to v1.9.2.
So I did a simple test program to confirm that it was nothing wrong in my code.

Here is the test code:

from direct.showbase.ShowBase import ShowBase
from math import pi, sin, cos

class MyApp(ShowBase):
    def __init__(self):
        # Open Panda3D
        useEgg = False
        if useEgg:
            # Load Egg file
            model = self.loader.loadModel("cube.egg")
            # Loadd obj file
            model = self.loader.loadModel("cube.obj")
        # Export to bam
        # Apply color
        # Reparent the model to render.
        # Move
        # Loadd bam file created from egg
        modelbam = self.loader.loadModel("cube.bam")
        # Apply color
        # Reparent the model to render.
        # Move
        # Add the spinCameraTask procedure to the task manager.
        self.taskMgr.add(self.spinCameraTask, "SpinCameraTask")
    # Define a procedure to move the camera.
    def spinCameraTask(self, task):
        angleDegrees = task.time * 6.0
        angleRadians = angleDegrees * (pi / 180.0) * sin(angleRadians), -10.0 * cos(angleRadians), 1), 0, 0)
        return task.cont

if __name__ == '__main__':
    App = MyApp()

If I run it with v1.8.1, models imported from both egg and obj files are colored, even after being exported to bam and imported again.
If I run the same code in 1.9.2 (and even 1.10) the egg model works, but the obj model cannot be colored, neither after being exported to bam and imported again.
Is it a bug? or I am missiing something?
cube.obj (2.6 KB)
cube.egg (2.28 KB)

This appears to have been a subtle change in how the .obj loader loads colours. It should work fine in either version if you pass an override value to indicate you want to override any value specified by the model file.

model.setColor((1, 0, 0, 1), 1)

Thanks rdb, it works now if I do what you say!