Set yourself at the FASTLANE using Panda3D (4 Windows only)

  • This topic was written for Panda3D under Windows.
  • This topic was written for both the beginners of Panda3D and the “next generationsâ€

Jo this is wonderful! Thanks heaps for taking the time to write this for us. You’ve put a lot of effort into this and it shows, well done!

I’m in a bit of a quandry now with my own guide, but I think I’ll leave it as it is (using the Command Prompt) that way, people will have two options on how they want to run their scripts :smiley:.

I also took a look at conTEXT very nice find indeed, I think I’ll download it and try it. I chose to use PyPE because that’s the editor mentioned in the manual (and I didn’t know of any others :unamused:).

But again, to give people more options, I think I’ll leave the instructions for PyPE as they are in my own guide. People can then try them both and see which one they like best. Having choices is a good thing :smiley:.

Thanks again for doing this for us.


Yes, that’s correct.
Let people know exactly what lies behind the scene, let them choose their own path and destiny.
All we can do is just show them the ways.
Hope God lights up the way.

Tiptoe, have you download the entire manual an reference?

Go to the manual, look at chapter VII.Panda Tools point C.Python Editors section, you’ll find some editors there.

Having the manual next to your pillow is a good thing !

ok im lost at:

and it would be nice to see what secrets those images revealed once, to!
and i did get the .PY file to be opened with the .BAT file!

Sorry, my host is still unavailable for the next few days.
Read this on :

Yes, of course you can run your .py files directly from the editor without setting those actions. Those actions are to ease you when you’re not involving your editor, i.e. in case when you only need to run them, instead of editing them.

Good luck !

np i can wait for the images to come back, thats no problem, ok ill get back to tutorials now (must keep diging!)

EDIT: ahh the images are back, how nice :3

sorry for the double post… a problem i encauntered was that i don’t thave that “advanced” button for the .PY

I believe it’s due to your Windows version. Which one is yours ?

i have win xp pro sp2 version 2002.

It doesn’t make any sense. It must be your misunderstanding.
After you type “py”, press enter or click OK, so that PY type is added to the file types list. By default, PY file type is automatically selected (highlighted), then you click “Advanced”. If it’s not selected, you can select it to make sure.

well thats the way it is… :unamused:

lol, do you notice something very odd on this screenshot?

Press restore, then delete and then make it again.

Took me ages to work that out.

ook thx ill try that out ^^