Segmentation fault when running any app in 1.6.1

Whenever I attempt to run an app, including the samples, I see the window open and can se the scene for a couple of seconds and then I get the following error:

I am running Ubuntu Jaunty. I am am on a laptop with an Intel graphics chip (940GM). I also had the same error running 1.6.0. Any help or direction in fixing this will be appreciated. Thanks.

This is probably not of much use, and I am sorry for that, but I felt the need to say that I do not get the same error with 1.6.1 on Ubuntu Jaunty 64-bit; desktop with Nvidia graphics card (G8800GT). Everything seems to work fine on here. Perhaps someone more knowledgeable can diagnose MojoX’s problem?

No, problem. I’m guessing it has something to do with my system. What I would like to know is what the “get fences failed” message might mean.

Can you run pview?
Also, can you give us a gdb traceback so we’ll know where to look?

No, I cannot run pview.

Here is the gdb traceback:

It appears to be crashing deep within your OpenGL driver. I suspect a driver misconfiguration. Are you able to run any other 3-D applications?


Thanks for the help. The problem does seem to be with the driver. Apparently quite a few folks who upgraded to Ubuntu 9.4 are having problems with the Intel drivers. Hopefully, the problem will be resolved soon. Again, thanks.

I appear to be having the same issue.

Dell D410
Intel 915gm onboard video
GLgears works fine
Compiz Fusion working perfectly

i’ve googled the issue but have not found a solution.
have also gone to and searched there, no solution

Does it run if you set:

load-display tinydisplay

in your Config.prc, replacing the “pandagl” line? This will configure Panda to use its own software renderer instead of your system drivers. If this works, it does prove that something’s not quite right in the communication between your drivers and Panda.


load-display tinydisplay
#load-display pandagl
#load-display pandadx9
#load-display pandadx8

received the following error:

:display(warning): Unable to load: /usr/lib/panda3d/ undefined symbol: XAllocSizeHints
Known pipe types:
(all display modules loaded.)
No graphics pipe is available!
Your Config.prc file must name at least one valid panda display
library via load-display or aux-display.

I had the same problem: ubuntu jaunty and intel video card. It seems this problem was addressed already in the next ubuntu release: … bug/378106

So the solution is to upgrade to ubuntu karmic.