sample apps run properly but when I do one it doesn't!

hi all,
I’m running ubuntu 13.04. after resolving the dependencies and going through the installation I managed to successfully run the sample applications in /usr/share/panda3d/samples

however when I make a script as simple as this one:

import direct.directbase.DirectStart

and try to run it with: python

I get:
DirectStart: Starting the game.
Traceback (most recent call last):
File “”, line 1, in
import direct.directbase.DirectStart
File “/usr/share/panda3d/direct/directbase/”, line 3, in
from direct.showbase import ShowBase
File “/usr/share/panda3d/direct/showbase/”, line 33, in
import Loader
File “/usr/share/panda3d/direct/showbase/”, line 5, in
from panda3d.core import *
File “/home/adam/workspace/python/”, line 3, in
NameError: name ‘run’ is not defined

when I run the same exact script in /usr/share/panda3d/samples
it works! so what’s going on?

You have a script, the name of which conflicts with a module that Panda defines. You should rename your and it’ll work.

that worked like magic! thank you!