Roaming Ralph really slow?

A courious incident took place when I started the Roaming Ralph example and found out it ran really slow.
It is not the first application to run like that on my PC (OpenArena and Nexuiz) had the same problems.
Photoshop, Blender, and even games like Gunz run smooth and perfectly.
Recently I downloaded the nVidia driver I needed because I was said the default one that windows 7 installed automatically sucked.

Any idea/explanation for this issue?

(Excuse me if I’m in the wrong section)

Thanks for reading & Good luck!

Hi and welcome to the forums.

Go into the Panda directory and look for a file called Config.prc in a directory called “etc”. There change the value of load-display from pandagl to pandadx9.
This makes Panda use DirectX over OpenGL, which is sometimes way faster depending on drivers.
You can read more on that configuration file here: … ng_Panda3D .

If this doesn’t help, send us some more specific information about your computer and your operating system. You can also enable the FPS meter through the configuration file and see how many frames per second you get when running e.g. pview, an empty window or ralph.

If you feel like being hardcore, you could analyze the whole problem with pstats, a performance monitoring tool that comes with panda. Look for it on the manual if you’re curious.

Have a nice day

Thanks, now it’s running perfect.

If I develop a game and I wish to make it multiplatform, the linux version should keep the pandagl configuration, am I wrong?

Thanks for helping and for the extra documentation!


Look for “aux-display” on the same page linked by Nemesis#13 - you may try loading DirectX and fallback to OpenGL.