resolution issue

I have a strange resolution problem. We have a pretty simple game with fairly lame graphics. We are running it on a projector whose native resolution is 1280x720. I use to be able to run my game at the native projector resolution, and it looked fine, but then something changed, and I have no idea what. Now when I run my game at this resolution, it tends to look choppy while turning, and generally seems to be running at a lower frame rate, which indeed it is. So at the resolution 1280x720, my frame rate drops to around 50fps, but if I set the resolution to 1024x768, frame rate jumps up to 120fps, and everything looks fine, although at a lower resolution, obviously. It was not a video driver update, which was my first thought. I have no idea what it was, but I have actually completely re-installed the operating system, drivers and software at this point (even playing around with not letting it do updates), and none of that has made any difference. The computer is running Windows 8, and I have tried both a recent development version of Panda3d, and the last stable version. This actually happened on two different systems running mostly the same hardware/software. Even weirder, if I run the Carousel tutorial, it runs at 120fps at both resolutions. What about my crappy graphics is causing this, or is it my code, or something else? And why would it change when my code and models did not? Any ideas? Am I just stuck at the lower resolution? I’m so completely mystified.


At a guess, it reads like a fill-rate issue: for whatever reason, you may be drawing multiple times to the same set of pixels. Do your textures perhaps have alpha channels, perhaps causing the models using them to be drawn as “transparent” (even when they’re fully opaque), and thus causing them to be drawn from back to front in order that the “transparency” be correct (thus preventing depth-testing from culling as much as it might)?

Otherwise, are you using source control, or do you have a sequence of backups? If so, then try going back through your versions/backups until you find the most recent version that works, then compare that with the next version. You may find some change that you’ve overlooked or forgotten that is causing the issue.

Thanks for the feedback. I do have version control for my code, but going back to earlier versions does not change this issue. The models have not changed. I am going to try making some new models, and see if I still have the same problem. I have noticed that with some of the models I have received errors when converting from egg to bam files, something about unused channels.

How does the resolution of the textures that you use in models affect the final resolution? Could it have to do with a different aspect ratio? I’m still not sure why it would be able to handle it one day and not the next, when nothing seems to have changed, but I think I may not get to the bottom of that one. Logs are failing me there.