RenderPipeline | Python crash :(


#1

Hi! I am new to Panda3D.

Today I installed the RenderPipeline, but I have a problem, when trying to enter some sample python crash. :neutral_face:

This is what is happening ->

In consola ->

I’m pretty confused. I do not speak English so everything is more difficult for me…

Panda3D without RenderPipeline works perfectly.

Could someone help me with this problem?
Thank you

Sorry for my bad English, I speak Spanish.

Regards!


#2

Hi,

Which panda3d version are you using?
A self compiled one, or one from the buildbot page?


#3

Hi!

Sorry for the delay and thanks for your response.
From here -> panda3d.org/download.php?pla … =devel&sdk
I am using the latest version available -> Panda3D-SDK-1.10.0pre-45356e8-x64.exe

I tried installing and reinstalling, but I did not get anything.

Regards


#4

I just downloaded the latest version available. I continue with the same error.
I wanted to use Python for this project, but apparently it does not work :frowning:
I’ll have to change engine. I’ll try with Unity3D u.u


#5

Do the regular panda3d samples work? What are your system stats?


#6

Hello.
I currently experience exactly the same problem as francoiz, even though Pipeline used to work before and Panda 3d samples still work.
Before it stopped working I started installing Visual Studio 10 to install C++ Pipeline packages and before the installation even finished, samples stopped working. Reinstalling the Pipeline didn’t give any results (and also I still can’t install C++ packages (CMake error at ‘blablabla’: The C compiler ‘blablabla/VC/bin/cl.exe’ is not able to compile a simpe test program.) I have to do something with VS, don’t I?).

So… How can I fix that? Thanks in advance.


#7

This indicates an issue with your Visual Studio installation.

Please note that the latest Panda3D buildbot builds for Python 3.5 and 3.6 are nowadays built with Visual Studio 2015.


#8

Thanks, will try updating VS soon. In fact, I only installed VS 10 because I knew for a fact VS 15 didn’t work as intended on my machine, but seems like I’ll have to find a way to fix that.


#9

I am facing exactly the same issue i.e python crashes when using render pipeline even when i run the render pipeline samples , whereas regular panda render pipeline as well as regular samples works flawlessly , My laptop specs are corei5 , 4gb of ram , 500gb H.D space and intel HD5500 graphics card , i compiled Panda3d myself from source code and have all the pre-requisites i.e VisualStudio2010 with latest patch applied as well as microsoft windows SDK 7.1 .
Can someone guide me as what exactly is happening and how to resolve the issue i.e python crash when using render pipeline.
thanks in advance !!