Render pipeline not working

no, I didn’t make them I’ve downloaded the Tobspr tutorial GitHub respiratory, and I’m running the Creating-A-Scene sample.
I just wanted a test drive through the Render Pipeline.

In a few minutes i’ll run the samples

INTERNET is slow

SORRY for no reply in days, I AM going to run it now…

(UHHH BASICALLY THE SAME ERROR) < read the before, I’m running roaming ralph
ERROR:
[>] CORE rpcore.native imported
[>] CORE Using panda3d-supplied core module
[>] RenderPipeline Using Python 3.8 with architecture win_i386
[>] RenderPipeline Using Panda3D 1.10.10 built on Aug 31 2021 07:17:5
9
[>] RenderPipeline Using git commit 47836f11d802762ef89d452dd6e33b31f
74c41f7
[>] MountManager Auto-Detected base path to /c/Users/Cherry.Venkat-
HP/AppData/Local/Programs/Python/Python38-32/Lib/site-packages
[>] RenderPipeline Mount manager was not mounted, mounting now …
[>] MountManager Setting up virtual filesystem
[>] MountManager Mounting auto-detected config dir: /c/Users/Cherry
.Venkat-HP/AppData/Local/Programs/Python/Python38-32/Lib/site-packages/config/
[>] MountManager Mounting ramdisk as /$$rptemp
[>] RenderPipeline No settings loaded, loading from default location

Known pipe types:
wglGraphicsPipe
(all display modules loaded.)
:display:wgldisplay(error): Could not create GL context.
:display:wgldisplay(error): Closing window because no valid context is available
.
:ShowBase(warning): Unable to open ‘onscreen’ window.
Traceback (most recent call last):
File “main.py”, line 314, in
w = World().run()
File “main.py”, line 70, in init
self.render_pipeline.create(self)
File “C:\Users\Cherry.Venkat-HP\AppData\Local\Programs\Python\Python38-32\lib
site-packages\rpcore\render_pipeline.py”, line 160, in create
self._init_showbase(base)
File “C:\Users\Cherry.Venkat-HP\AppData\Local\Programs\Python\Python38-32\lib
site-packages\rpcore\render_pipeline.py”, line 476, in _init_showbase
ShowBase.init(base)
File “C:\Users\Cherry.Venkat-HP\AppData\Local\Programs\Python\Python38-32\lib
site-packages\direct\showbase\ShowBase.py”, line 339, in init
self.openDefaultWindow(startDirect = False, props=props)
File “C:\Users\Cherry.Venkat-HP\AppData\Local\Programs\Python\Python38-32\lib
site-packages\direct\showbase\ShowBase.py”, line 1021, in openDefaultWindow
self.openMainWindow(*args, **kw)
File “C:\Users\Cherry.Venkat-HP\AppData\Local\Programs\Python\Python38-32\lib
site-packages\direct\showbase\ShowBase.py”, line 1056, in openMainWindow
self.openWindow(*args, **kw)
File “C:\Users\Cherry.Venkat-HP\AppData\Local\Programs\Python\Python38-32\lib
site-packages\direct\showbase\ShowBase.py”, line 801, in openWindow
raise Exception(‘Could not open window.’)
Exception: Could not open window.
[>] MountManager Cleaning up …

We understand you, but we need to find out some details.

Does it work?

from direct.showbase.ShowBase import ShowBase

class Game(ShowBase):
    def __init__(self):
        ShowBase.__init__(self)

app = Game()
app.run()

it sureully works, check out the output:


is this correct?

I am kind of not in a hurry @serega-kkz.

wait sorry, I ran the render pipeline samples - roaming ralph - if your talking about the normal samples, EVERYTHING works. I’ve ran this
so I ran 02-Roaming-Ralph.
and the error above in this forum is for 02-Roaming-Ralph. The normal panda3d samples WORK.

Yes, I was talking about normal samples, if it works, then it’s already good.
Then you need to take a look at the Render Pipeline configuration file, config/panda3d-config.prc

Maybe he is the problem.

uhhhhhh where is that located? And I don’t know how to fix it.
I am not being offensive, but, How?

I do not know about the version with pip, I think you’d better install from github.

I’ve installed render pieline through pip’s git installer thing.

I have to wait a bit…
like an hour or two, because I’m snoozy busy…(sleepy)

If you need, I’ll find the version of PIP after the ‘bit’ - thing - ‘break’

yep

NAAHHHH, i dont need a bit

fine, here you go, pip - 21.2.4 - found when I typed in ‘pip --version’
OUTPUT:
pip 21.2.4 from C:\Users\Cherry.Venkat-HP\AppData\Local\Programs\Python\Python38
-32\lib\site-packages\pip (python 3.8)

and what do you mean by “you’d better install from github”

helloo