reassign was not declared in this scope - ArchLinux 64bit


I tried to compile panda3d on a 64bit ArchLinux. I tried

makepanda/ --everything


makepanda/ --nothing

The error is:

built/include/nodePointerTo.I:136:3: error: ‘reassign’ was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]

I fixed this error by changing the reassign rows in panda/src/express/nodePointerTo.I:





Since I don’t know C++, I don’t know if this is a bug or not. It’s also possible that this change isn’t the correct solution, but maybe this post helps someone else to compile panda3d.

If you need any further information, just ask.

Heh, I was just about to post this, too :smiley:

Also showing up on arch-32bit

gcc version: 4.7.0
python2 version: 2.7.2

I had the problem in

And applied the exul’s changes on 1.8.0, resulting in a complete compile.

Other than that, it was very nice. I particularly liked the option to apply multiple threads to the compilation. :slight_smile:.

I wonder, is Nemesis#13 on arch also?
(Peeks at profile) Think so.

Yeah, I had the problem on Archlinux 64bit.

But I just switched to ubuntu two days ago, so I don’t really care about this.

Sounds like another compiler bug. I’ve just committed your workaround, thanks.