PyPE not working for my friend.

Recently I recommended that my friend go out and download PyPE (which, btw, works great for scripting). However, it doesn’t work for him! He gets it downloaded, but when he types in codes, and tries to run the file, it says “cannot read file (Filename)”.
I tried using the same exact code he did on mine, and it worked. Why is this?
How can it be fixed?


Sorry, actually it says:
"Error: I don’t know how to run file type: u’filename’ "
Any reason this might be?
We still haven’t figured it out yet, and I cannot find any posts about it online.

Hmmm… Do his file-names end in “.py”? It looks as though the program is encountering a file with an extension that it doesn’t recognise.

Otherwise, could you please post an example file-name (including extension) here?

[edit] In fact, it looks as though he’s somehow naming his file .filename, which might mean that he’s doing something odd when saving them…

Hm. You were right.
He didn’t tell me it didn’t save as a .py file.
Cool, thanks so much