PyDev can't load Panda3D modules

I use Eclipse with PyDev All I get when I try to run the grassy model, is:

import direct.directbase.DirectStart

ImportError: No module named direct.directbase.DirectStart

Kind of odd if you ask me.
I use the same DirectStart, and mine works fine.

I use PyPE to run my files.
You can download it here: … PyPE.shtml

Basically, I’m sure it’s near the same thing.

BTW, It happens with all the DirectStart.

Check the PYTHONPATH part of the project settings.
Sounds like you don’t have panda3d in the PYTHONPATH in PyDev.
You will still get lots of warnings/errors even after you fix this, but if you run the program in PyDev it will work.

Amm, I tried that before, Did not worked.
Also, Will it work better in PyPE?

I do not use PyPE.
Just using eclipse and PyDev has been fine.
Willing to show the code?
What system are you on?

Mac os for example, has multiple pythons.
Are you sure panda is installed for the python you are using?
Look in eclipse, and find the location of the python interpreter that eclipse is set to use.
Run that python from command line (with full path), do your import and see what happens.

In a shell for example:
$ /full/path/to/python

import direct.directbase.DirectStart

I am using Python Standard Library 2.7.3…
Also, I will give PyPE A try and than decide how to continue.

Also, Anyone Recomends GNU Emacs?