Pview crash running under Win98

Hello guys.

I did my initial “wow, look at that!” :slight_smile: play-around with Panda3D on a work PC running Windows 2000. I had no problems on that platform, but its a different story on my home PC where I’m running Windows 98SE.

I can run the 5th (final) tutorial in the first set of samples regarding scene-graphs, with no problems. So, my installation is not completely borked. However, if I run pview or x2egg it crashes with the following error message:

PVIEW caused an invalid page fault in
module LIBNSPR4.DLL at 017f:30021ab5.
EAX=afe4e072 CS=017f EIP=30021ab5 EFLGS=00010202
EBX=8255cd01 SS=0187 ESP=0121f808 EBP=00000003
ECX=8255ce34 DS=0187 ESI=00000000 FS=3eef
EDX=30020460 ES=0187 EDI=00000000 GS=0000
Bytes at CS:EIP:
8b 14 81 8b 82 08 00 00 00 eb 0c a1 58 b2 02 30
Stack dump:
30017042 bff75770 00000001 0121fa94 8255cd01 bff741f7 82568d54 3001794a
00000001 30020460 00000000 00000003 00000001 00000000 00000000 00000000

I have checked that the Panda3d bin directory is in my path, and moreover is at the very front of the path. I have searched my hard-drive for LIBNSPR4.DLL, and the only entry that comes up is the file in the Panda3d tree, ie., Pview is not picking up a corrupt version from elsewhere. Also, unlike my Win2000 experience, under Win98 when I run Pview the floppy-drive is activated, as if Pview is searching everywhere it can think of for some file.

I was originally running Panda3D 1.0.3, I uninstalled that and went to v1.0.5, but it had no impact on this problem.

I did a quick Google search on LIBNSPR4.DLL, and it was suggested that this file was a WinXP dll.

So, did I miss a great flashing neon-sign on the Panda3D front page saying “Windows 2000/XP only”? :slight_smile: Or is something else amiss?

Thanks once more for your time,

My apologies for the cardinal sin of replying to oneself, but I think I have solved the problem.

I grabbed a Win95 version of the nspr library from the following link:

dlldump.com/download-dll-fil … llfiles/N/

I copied this file to the Panda3D bin directory, deleted the original ‘libnspr4.dll’ file, and renamed ‘nspr4.dll’ to ‘libnspr4.dll’. Pview is now working. :slight_smile:

I don’t suggest other people follow this procedure, downloading and running random dll’s can be a risky procedure, and I’m running a virus-check as we speak. But, if nothing else we have isolated the problem. Seems to me the question now is: was my Win98SE install foo-bar, or does the Panda3D install procedure need to be updated for Win98 users?


Interesting. I didn’t know that the NSPR distributed with panda was XP-only.

I guess I could fix makepanda to choose the right libnspr. Also some changes to the executable installer.



I’m sure you’re at least as Goole-literate as myself, but on the off chance it saves you a few minutes, here are a couple of links mentioning the libnspr4 / nspr4 (WinXP / Win98) distinction :

opensubscriber.com/message/m … zilla.org/
1400402.html … awler.com/


Although we no longer distribute NSPR with Toontown, we used to, and we distributed just the one version, which I guess was the Win95 version. It worked fine everywhere. One time we did accidentally distribute a different version which didn’t work on Win98; I guess that was the NT version. We went back to the original version and it worked everywhere again.


Not really… as far as I can say (a little bit bad mind) I switched to win2k because I have had trouble running Panda3D 1.0.5 using Win98SE. At least I have had serious trouble with several games that kept not-working using ‘98.
I THINK Panda3D was one of them that finally made me movin’ - however, nice that it should be back working…
That for the Windows-Part of the Panda-Installation :slight_smile:

Geh, I guess this post can be considered as spam :blush:

Regards, Bigfoot29