Problems with UBUNTU 9.10

Hi everybody! I’ve installed new UBUNTU, 9.10, tried to load Panda, but without any success (everything seems to work fine, but it shows only the grey screen and nothing else). Tinydisplay mode doesn’t work. Please help, for me it’s very inportant to make it working again!

Have you also installed graphics driver ?
Post the whole console output.

kristal@kristal-laptop:/media/DataDrive/Documents/Game/game/trunk/src$ python
DirectStart: Starting the game.
Known pipe types:
(all display modules loaded.)
:audio(error): _system->init(): Error initializing output device.
:audio(error): FmodAudioManager is not valid, will use NullAudioManager
:audio(error): _system->init(): Error initializing output device.
:audio(error): FmodAudioManager is not valid, will use NullAudioManager

That looks like perfectly normal startup messages, except for the fact that your audio library isn’t working. Other than that, though, I don’t see anything wrong with Panda. Are you sure your file is doing anything other than a gray screen?


Yes for sure, and examples work in the same bad way

Anybody help please!!!

Put this in your Config.prc and post the output :

notify-level-glgsg debug

I forgot to register and post this yesterday when I had my laptop with me, but I tried compiling Panda 3D on Ubuntu 9.10 and got the exact same behaviour as Kristal.

I have an Intel chipset, using the intel driver (Compiz works, glxgears too), and it’s a 64bit machine.

Yet I still have to try enabling first tinydisplay, then provide the additional info ynjh_jo asked for.

Also, it’s my first time trying to get Panda3D up and running, so pardon my lack of knowledge, but I couldn’t find any Config.prc file when installing Panda3D from the .deb package makepanda generates. There is one on the built subdirectory of the source tree, but that’s it. Maybe I need to copy that one somewhere, but where ?

Anyway, I’ll come back later when I’ll have some more time to investigate this problem.

It’s in /etc

So, using tinydisplay doesn’t even let the sample programs start, they crash with this output :

Using notify-level-glgsg debug gives me this :

Hope that helps narrowing down the problem !

Hmm, lots of people it appears have been having similar problems with Ubuntu and Intel cards. In general, they all appear to have solved their problems by updating their graphics drivers. See these threads:

The tinydisplay problem is an unfortunate build problem, which I believe has been fixed for 1.7.0.


Yeah, seems like the drivers caused a lot of problem on Ubuntu 9.04 (but not the one described in this thread, however), but even updating to the bleeding edge version of the driver didn’t improve things.

Too bad, I guess 1.7.0 to see if I can at least get the software renderer to work until hopefully the intel drivers get fixed… Thanks for the info on that !

According to Ubuntu forums, the Intel driver issues in 9.04 is already fixed in 9.10.

Try to adjust notify level severity from “debug” to “spam”.

There you go :

I scanned through the output, but can’t see anything weird myself, seems to me like it’s working correctly… except that it doesn’t get drawn on the screen…

I can see panda already does the job, clearing the framebuffer, setting matrix, drawing geoms, and repeats.

  1. What’s the result of “print” ?
  2. I assume you pressed escape to close it, instead of killed the process. If so, nothing is obviously wrong within panda. … oblem.html