Problems with Fedora 8 64 Installation

Hello guys, I´m new in the forum and i´m having problems with installing Panda3d in Fedora 8 64 bits, i used the automated build 2008.2.28 and the install happen without any problems, but when i try to compile my applications, that i tested in fedora 5, it doesn t work correctly, even in the sample programs, is this a configuration problem or installation problem? And how can I solve it?
Thanks for the help!

ps.: Sorry, if i´m not in the right section

I’ve never tried running a 32-bit panda on a 64-bit linux. I vaguely seem to recall somebody saying that it works, but I wouldn’t know.

If by “compile your applications” you mean you’re developing in C++, I’m guessing it will be necessary to either compile your applications in 32-bit mode (to match the way Panda is compiled), or build your own version of Panda which is compiled in 64-bit mode.


When he says “even in the sample programs,” I assume he means that the sample programs aren’t running?

Here’s the thing… when you install one of these packages on an OS other than the one it was compiled for, you’re up against all sorts of compatibility issues. Especially issues having to do with running the wrong version of python - Panda3D is compiled for just one version of python, it won’t work if you use it with some other version. If it was compiled for a 32-bit python, and you’re trying to run it with a 64-bit python, I’m sure it won’t work.

Thanks everybody for the answers, yes, the sample programs aren’t running… i think the only way is to compile it from source… But the Panda3D build packages are only available for 32 bits OS?

Dude, I’ve installed eight different versions of linux on my computer here. That’s all I’m going to do.

Dpsm compiling from source is not that hard once you get all the libraries it needs.

i know it’s not so hard, but i’m not in the computer that have fedora 8.
And congratulation for the job, Panda3D is an excellent game engine, and very easy comparing to the other language/library that i was using, and Josh, i didn’t mean to bother you, sorry

Compiling it for 64 bit is impossible without some pretty low level changes, so unless you know c++ reasonably well I wouldn’t try. However, I’m currently trying to get it running on 64 bit Ubuntu Gutsy, and have it building a .deb package that installs fine but doesn’t run - null pointer being used to construct a basic_string crashes it on start up. But then, I only started yesterday. I’ve also had to drop all sound support and ffmpeg support to get it that far, but I might go back and fix them latter - it actually compiles both OpenAL and ffmpeg, but falls over with the linking step for different reasons.

Anyway, unlike when I ported the 1.34 version (It only took me a day for a reason…) I’m doing it properly this time, so when done I’ll submit the changes back so they can hopefully go into cvs, and it should start working. Of course, if its only regularly compiled for a 32 bit OS then someone will break the port sooner or latter;-)

Because it not works in 64 bits fedora, i tried this time in fedora 5 32 in another computer, and when i try to compile the sample program asteroids it show this errors:

[danielpires@localhost Sample-Programs–Asteroids] ls models screenshots textures [danielpires@localhost Sample-Programs--Asteroids] python
DirectStart: Starting the game.
Traceback (most recent call last):
File “”, line 13, in ?
import direct.directbase.DirectStart
File “linuxroot/usr/share/panda3d/direct/src/directbase/”, line 3, in ?
File “linuxroot/usr/share/panda3d/direct/src/showbase/”, line 10, in ?
File “/usr/share/panda3d/pandac/”, line 1, in ?
from libpandaexpressModules import *
File “/usr/share/panda3d/pandac/”, line 1, in ?
from extension_native_helpers import *
File “/usr/share/panda3d/pandac/”, line 20, in ?
from libpandaexpress import *
ImportError: cannot open shared object file: No such file or directory

i think it is not “linking” the libraries of panda, how could i solve it? Thanks again for the help!