Problems getting a higher frame rate

I’ve been working with Panda for about a month now, and I’ve seen that alot of samples and screenshots of people’s work are getting up into 100+ fps. My programs, no matter how simple, are revolving around 60 fps. I was wondering if there is a configuration variable that I need to change, or a change in clock mode, or if it is simply a hardware side issue (I doubt its a limitation with GeForce G8800).

I’ve used pstats and it appears that on simple programs, it is doing alot of waiting, which leads me to believe that there is a default frame rate set somewhere. I’ve done alot of searching and still haven’t found anything about it, let alone how to change it.

Thanks in advance…

It’s synchronized to your monitor’s refresh rate by default.
Use “sync-video 0”.

…wow…thanks alot. I can’t believe I missed that… I figured sync-video was more for getting rid of render clipping (or is that the downside to having it turned off…). I wanted it for debugging purposes…to see if implementing something caused a dramatic decrease in fps; but at 60 I wasnt seeing anything until system was pretty much overloaded anyway.

Anyway, thanks again. Now back to figuring out why my antialiasing isn’t working…

Does this go in the “Config.prc” file?

That’s right. Alternatively you can use the following expression in your python code:

from pandac.PandaModules import loadPrcFileData
loadPrcFileData("", "sync-video 0")

I prefer to use this version myself for all config stuff :slight_smile:

Or you can create your own file and load from that.

from pandac.PandaModules import loadPrcFile

For that matter, any file named foo.prc, placed in a directory named by $PRC_DIR (or maybe $PANDA_PRC_DIR? Not sure how it’s built here), will be loaded automatically.


In binaries generated by makepanda, the env vars are called $PANDA_PRC_DIR and $PANDA_PRC_PATH .