Problems exporting a Model from Maya 2009

Hello Everyone,

I am new to the forums here. I just installed the Panda3D SDK and attempted to do some test exports from maya with little luck. I tried multiple methods, of export following the online manual.

When running the export via command line I get the following:

initializing Maya.
vent_phong2.mb (kFailure): Unexpected Internal Failure
:maya:mayaegg(error): Unable to read vent_phong2.mb
Errors in conversion.

When I try to export via the Panda3D Tools GUI I have two problems, first simple export, I get this error:

Traceback (most recent call last):
File “”, line 1455, in SimpleExport
File “”, line 1500, in RunExport
KeyError: ‘quotes’

And if I try to run the advanced version I have no row of buttons at the bottom bellow the batch render list so I can’t initialize it.

Finally, if I run the mel script MayaPandaTool.mel I get the following error in a Microsoft Visual C++ Runtime Library Window:

Program: C:\Panda3D-1.7.0\bin\maya2egg2009-wrapped.exe

An application has made an attempt to load the C runtime library incorrectly. Please contact the applications support team for more information.

BUT I have the check box for preview in pview selected and after dismissing the error window the model loads fine into pview. I know this is a rather lengthy post but I could really use a bit of help, I am just stabbing in the dark here on my own. thanks alot.


Hmm, this has come up before. There is a cheesy workaround, which is to install the Microsoft Visual Studio C++ Compiler Express Edition. That seems to work around the problem for some reason that we don’t yet fully understand.


Thanks for the quick response David. I went to: downloaded and installed Visual C++ 2010 Express, then restarted. I attempted to export via mel script and same popup error happened.


Hmm, perhaps it is important to install Visual C++ 2009 Express instead? That is the version used to compile Panda, and maybe only installing that version solves the runtime issues.


no dice. same thing happens. GRRRRRRRRR.