Problem with vertex Alpha Blend

I have a problem with setting alpha blend in panda3d

this picture on XNA

and this on panda3d

I don’t know how to setting or changing it
Can some one help me ?

Add some lights (e.g. ambient+directional) and enable the shader generator (to get per-pixel lighting) with: render.setShaderAuto()

For this particular scene, I don’t think you really need the shader generator; but wezu is absolutely right: your scene looks flat because you have no lights.


thx for all :slight_smile:
It gone work

maybe the shader generator should be enabled on render by default?

not because it’s good practice, but because if somebody tries panda3d, it should “look good” ™ by default.

/me is going to get punished for this comment ^^

Hypnos, I actually agree here, maybe add a directional light and some cool sun shadows and SSAO? Maybe make the “unextured” stuff have some sort of clay material and generate normals if it does not have. So when any type of junk gets loaded it looks like this ?

No i am not being sarcastic i also think that providing cooler look (which can be disabled) by default can be a good thing.

No way.

Yeah. That’s just silly.

Panda should always render what the developer asks it to render; trying to guess what the user would really rather see is kind of preposterous.

If you wanted to write a standalone program, akin to pview, that made this kind of intelligent improvements to a model, go for it, and good luck to you. But it would have to be clearly documented that this viewer is magical in that way; and we certainly shouldn’t attempt to do anything like that in the core engine.