problem with BlendEquation and BlendColor

a while ago my laptop got stolen. i just got another one but its not as good as the one i had…

anyway, the point is, i installed panda 3d, and got it working, but when i run some of the sample programs, the code ends up saying this…

apparently, there is some issue with “BlendEquation” and “BlendColor”

how do i fix this?

also, whenever i run the “normal mapping” tutorial program, it says in the lower right “Video driver reports that shaders are not supported.”

i’m guessing that just means my video card is old, but maybe someone knows of a way to fix this too?

i can only hope someone can help out with either of these problems.
[/code]

It just means your video card is not so good. What video card do you have?
Maybe installing the latest drivers from your video card vendor’s website will solve the problem.

I updated my drivers and now panda3d programs just close as soon as they open.

No doubt it’s printing some error message to the console window that would be helpful for understanding what’s going wrong. Can you run from the command window and report what it says?

David

Try switching to DirectX instead of OpenGL

I ran a python program from the command window and this is what showed up on the screen.

What is the exact model of laptop you have?

This is a known problem with certain graphics drivers. See this thread for a workaround: https://discourse.panda3d.org/viewtopic.php?t=6541

David