Problem in converting from .mb to .egg, mental ray for maya

Dear All,
I am new to game designing, new to graphics designing, new to python, new to panda3d, new to 3d max, and new to maya, so please go easy on me, and use simple terms :slight_smile:

After doing several objects and texturing them in maya, then using the panda3d exporter through the cmd, then loading them into a panda3d program, it all worked just fine!
Then, after I created a really large terrain with several objects on it, and tried to convert the .mb to .egg file, I keep getting this message back from the cmd, and no files are created!

initializing Maya.
:maya:Reading Landing1-M.mb
mental ray for Maya 2012
mental ray:version Feb 2 2011 revision 138829

then returns command to me
I dont get what this means, please help

Thank you

I resaved the project without any textures, and when I converted it into panda3d, it worked and loaded, but ofcorse, without any texture.

So the problem seems to be in the texture, although I am 100% sure that I didnt use any but the Phong Material, and only image files

I don’t use maya, but it sounds like you’re using a procedural texture. You have to bake textures to an image file to use them.

It could also be the UVs (texture coordinates), maya has some smart mapping tools that don’t work with panda.
You can check the egg file if it has uv data, any text editor is good for that.

If the texture file is in the wrong place panda or pview would write a warning to the command line, so I don’t think that’s the case.

Thank you both for your quick reply, and after retexturing the objects again, one by one, and then testing if they work, it worked normally this time, I do not know why, but the good news is that it worked :slight_smile:

once more, thank you :slight_smile: