Problem Exporting Animation from Blender 2.49b, Chicken R91

I have skinned a new body mesh by importing an animated skeleton armature from another model, making local, moving/sizing the mesh so it’s on top of skeleton then Object Mode>Right click to select body mesh, shift right click to also select armature skeleton, Ctrl p>(Make Parent To)>Armature>Create Vertex Groups? >Create from Bone Heat (which in earlier versions was create from closest bones).
This all works and the mesh animates in Blender when I use Object Mode>View>Play Back Animation, but when I use File>Export>Chicken R91 there is no ‘Add Animation’ or ‘Animation Only’ buttons and the export doesn’t include the bones or the vertex groups that were created based on them, the way it does for the original animated model I imported the skeleton from.
I notice in the Outliner the structure is quite different for the two models:
-In the original the mesh and the armature are both at the top level, and the mesh has a reference to the armature under ‘Modifiers’;
-In the new model the armature [3D axes icon] is as the top level with an armature [stick man icon] and the mesh [3D axes icon] below it.
Any ideas?


Verify if your bone animation is in Action Editor before export. If not dot it or Chicken Export cannot know what animation channel use.

[ ]s

Yes, the animation is in Action Editor and when I click on various frames in the Action Editor panel the animation in the 3D view jumps to that pose.

There are two ways of applying an armature in the Blender 2.4x series - parenting and by modifier. Chicken only works with the more recent modifier method - sounds like you have used parenting.

Actually, they both work. When you parent a mesh to an armature, an Armature modifier is automatically added. You just need to click on the “make real” button before export, as usual.

Anon: As I explained to you last time you made that claim - the ‘Make real’ button converts from the old mode to the new mode. It remains the case that parenting does not work, even if Blender provides a button to convert from one to the other.


Before export did you select only the mesh? You don’t need select Mesh and Armature to export. Sorry if is not the case … but i guess we are forget some simple trick thing :confused:
When you export you can see , at last, the mesh in chicken preview ?


Did you receive some warning in Chicken screen?
A long time ago i have the same problem. Then i disable, in Armature modifier, the option Envelopes 'cos Chicken don’t recognize Envelopes influence.

I recommend you to use the same version of Python with Blender and Panda. That means going back to Blender 2.48a.

Thanks lethe. I removed the parent armature from my mesh and added my armature as a modifier. The export now works fine, including the animation.
I assume it has worked out the relevant connections between the individual bones and the corresponding named vertex groups, and it looks from the Chicken doc.html as if you always need to parent the mesh to the armature first using Bone Heat to create the appropriate named vertex groups, then un-parent and add the modifier, which is what I did by accident; do you know if that’s the only way to do it?
My only remaining problem is that I don’t seem to be able to repeat the Blender steps I used for appending an armature from another .blend file in the first place – I use the steps I thought I’d used before but now nothing gets appended! :astonished:(

You don’t have to remove the parented armature - just hit that ‘make real’ button Anon mentioned to convert from parenting to a modifier. The ‘link’ between vertex groups and bones is done entirely on matching names, so disconnecting and reconnecting is entirely equivalent, equally you can just create the vertex groups manually and give them names identical to your bones, though that gets tedious - heat weighting is usually a good starting point. As for automatically creating the map, yes, the parenting method is the only way to get that option that I know of - at least Google wouldn’t tell me another way of doing it, when you would expect there to be one!

Can’t really help with appending armatures without anything specific. It should work, but there are a bunch of potential gotchas - make sure you are selecting an armature, and not an object/mesh etc. with the same name, or a bone! (I have been confused by that part of the interface myself.) Note that it might be working but there might be a visibility issue (Sometimes blender forgets to refresh after appending, or it could be on a different layer, hidden or imported as a child of a hidden entity.) - check the outliner for its existence and the console for errors.

Thanks again lethe, I’ll do some more investigation.

There are two ways of applying an armature in the Blender 2.4x series - parenting and by modifier. buy levitra online Chicken only works with the more recent modifier method - sounds like you have used parenting.

I also tried to export this to a .egg file, but it’s saying “no animation” in pview…

Using Blender 2.49b
Chicken R91 version

I originally generic cialis parented the armature to the mesh (followed an animation tutorial), but then switched it to a modifier after learning that parenting doesn’t work with the chicken exporter.

Anyone specifically familiar with my situation?