Pfreeze error

I’m using pfreeze to create an executable out of a few modules for a game, and I got this error:

Could not locate the Microsoft Windows Platform SDK! Try running from the Visual
 Studio Command Prompt.

It’s not exactly an error, but pfreeze doesn’t produce anything. I tried installing the SDK and it didn’t work and then I tried the Visual Studio command prompt also, but it didn’t work either. How do I fix this?
(here’s the code i’m executing

C:\Panda3D-1.8.1\python\python.exe -m direct.showutil.pfreeze -i toontown.*.* -i
 otp.*.* -i pytz.*.* -i libpandadna.*.* -i direct.*.* -i pandac.*.* -i encodings
.* -i base64 -i site -o TTHREngine.exe toontown.toonbase.ToontownStart


I think 1.8.1 might still be requiring an old Platform SDK (2003 R2) and MSVC 2008 compiler. If you try a development build of 1.9, it may be content with the Windows 7 SDK and MSVC 2010 compiler.

Is the right thing? The only other thing I could find was this and it seems like it’s right, but the link is broken.

I don’t know. I suggest you use 1.9, which will be released soon.

Is that the one on github or is it not for the public yet?

GitHub should be fine.

Experimental builds are available from here. … 80a61c5ab/

You cannot freeze TTH source. Even if you do, it won’t work. Only Nirai can run it.